Jump to content

Recommended Posts

Really old bit of kit, but it plods on and does the job.... until now.

Two of the switches have stopped working. The extraction works, the naumkeag doesn't and the tool shaft doesn't.

 I isolated the machine and tried changing switches around, extraction to tool shaft then tried it. The extraction still works, tool shaft doesn't.

The bit the switches are wired to (i'm not knowledgeable in this department) some kind of switch pack thing is the problem i thing. There is a little brown 'tab' that clicks in when the extraction switch is operates, and clicks back out when it stops, obviously making a connection. When I push it in on the other two (with a piece of wood) they start, both tool shaft and naumkeag

Anyone got any ideas where to get replacements? or repair?

cropped.jpg

Share this post


Link to post
Share on other sites

They're magnet based and the coils will have gone. A simple try is to drown them in wd40 (nothing else as some others don't like electricity) or you have to fit modern equivalents which may have slightly different wiring. It's single phase by the look of it? You could just simplify with an on off surface mounted switch - doesn't look so good but would work

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...