Jump to content
Sign in to follow this  
algsoul

r s t 3lever steel union blanks problems

Recommended Posts

 hi had a few 3 lever union keys back of late 

re cut them and checked machine but still back        looks like the bit just set off centre

tried old stock and no problems   all work fine

anybody else ????

Share this post


Link to post
Share on other sites
18 minutes ago, ponsaloti said:

The weld is crap as well.

We've had a few flags drop off as soon as they were threatened with a blade.

 

We have seen this as well and it is causing me serious problems, had 10 out of 10 rim keys where the blades snapped off luckily i still had old stock at the back of the peg.

Share this post


Link to post
Share on other sites
1 hour ago, marky111 said:

i complained to davenports about their rim key flags breaking and said it was my fault and my bad keycuttung

 

bad business they need to think about there customers first 

Share this post


Link to post
Share on other sites

Seen this problem a few times over the years, usual response is "your cutter needs replacing" the fact that a new packet of ten had five broken broken off before opening the packet seamed to go over their head.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×